Version 5

<< Click to Display Table of Contents >>

Navigation:  Getting Started > KeepTool Release Notes >

Version 5

Previous pageReturn to chapter overviewNext page

Version 5.3.0 (2003-03-19)

A new facility for exporting the SQL results grid and table contents to a Microsoft Excel spreadsheet has been added.

Version 5.2.4 (2003-02-21)

A new facility for generating new user connections, and for switching new connections within Hora, has been added to the menu bar and to the Toolbar.

Syntax highlighting for reserved words in code editing windows now includes more new 9i words.

The Current Schema combo box in Hora has been expanded in length, and the schema name, followed by a colon, has been added to Hora's title bar, when a schema other than the connected user's is being viewed.

Version 5.2.3 (2003-01-26)

Enhancements to PL/SQL Debugger to maintain variable watches in triggers between invocations, and to enable variable watches in global package variables.

In Reverse DDL, a new option determines whether the check-box list of database objects should appear checked or not checked when opening the application.

When executing SQL from either the SQL Workbench's code window or the standalone Editor, it is now possible to turn off automatic save prior to execution, through a checkbox in the Extras | Settings menu item.

When updating from the results grid in the SQL Workbench, it is now possible to select either Commit or Rollback after posting changes.

Version 5.2.2 (2002-11-08)

The Grant and Revoke modal dialogs, available on the Privileges tab of certain objects, now allow privileges to be granted to or revoked from multiple roles or users at the same time.

Additional columns pertaining to Object Tables have been added to the Overview Tables sheet.

The Oracle Online Documentation feature now offers access to all versions of Oracle 8i and Oracle 9i documentation.

Interface to Resource Manager updated to support new Oracle 9i parameters.

The Database | Roles sheet now allows selection of either Roles or System Privileges, in order to show grantees of all System Privileges.

Version 5.2.1 (2002-10-02)

Automatic Code Completion can be enabled or disabled through the Extras menu item.

Automatic Code Completion  now completes an unfinished designator after a pause or Ctrl + space. If Enter is pressed, code completion resumes in the same case as the previously entered text.

In SQL Workbench, root nodes on a network drive are now shown using a distinct icon. Items are now sorted alphabetically.

Version 5.2.0 (2002-09-16)

Reverse DDL Generator now creates DDL for tablespaces, and is available through Hora's context menu.

The Overview Tablespaces sheet now includes the tablespace number.

SQL Logging is now called SQL Recording, and can be toggled on or off through the Extras menu, as well as from the SQL Preview window.

The SQL Repository is now file-based. SQL that was previously stored in the Windows Registry can now be imported. SQL Recording can designate a destination file through the new File Explorer tab.

New Code Completion menu item under Query on the SQL Editor context menu. This feature also appears automatically when entering a table name, alias name, or package name, followed by a period, in a SQL statement.

The DBMS_Profiler Oracle-supplied package can be invoked through a new toolbar icon from SQL Workbench.

In the SQL Editor, color-coding now distinguishes between successfully- and unsuccessfully-executed statements. Problem statements can be corrected in the editor window, and the code can be re-executed.

SQL Editor automatically creates Bookmark 0 in front of the first statement.

A new MRU (Most Recently Used) tab has been added to the bottom of the Overview Tables sheet. This limits the view to those objects that were most recently selected, using one of the tabs at the top.

A new two-part combo box appears for selecting the schema to be viewed. The top part lists the most recently viewed schemas. The bottom lists all schemas in the Data Dictionary that are accessible to the current user.

The new Analyze option on the Overview Tables sheet allows the DBMS_STATS package to be used for statistics gathering.

The Overview Materialized Views sheet now shows privileges granted and the relevant initialization parameters.

A new tab, Long Operations, has been added to the Sessions page.

The Triggers and Foreign Keys menu items on the Schema menu have been replaced by Triggers Global Management and Constraints Global Management.

Improved error flagging for PL/SQL object and trigger compiles.

New Update Comments column on the Initialization Parameters tab of the Database page (Oracle 9i only).

New Firing Order and Level columns on the Triggers tab of the Tables page.

Data that violates constraints can now be updated directly in the Show Exceptions dialog of the Constraints tab of the Tables page.

Views can now be updated directly, using the Data Contents tab of the Tables and Views page.

Version 5.1.3 (2002-03-08)

Changes to the Tables | Data Contents tab sheet

oThe Create INSERT Script menu item now prevents all previously hidden columns from being included. This feature enables partial comparison of tables belonging to different databases.

oThe new Create UPDATE Script menu item generates a similar script containing UPDATE statements.

A new Logging context menu item lets you choose whether tables and indexes should have logging on or off.

A new Create Export Parameter File menu item has been added to the Schema menu item of the main form. It allows you to create a parameter file that controls Oracle's export utility for multi-table exports.

It is now possible to add new partitions to a hash-partitioned table, using the Add context menu item of the table partitions grid.

Reverse/DDL now allows you to choose between the following methods of computing the START WITH value for sequences:

oOriginal start value used to create the sequence.

oLast number used: this means that the DDL statement starts with the current sequence value. This option is very useful once you have run the DDL script to create the schema structure and used Oracle's import utility to load the data.

oAlways one, regardless of the original start value and the last number used.

The Change Current Schema dialog, which used to appear when you clicked on the schema button to the left of the status bar, has been replaced by a combo box. Its built-in most-recently-used list eliminates the need for a dialog.

The Tablespaces | Datafiles sheet now shows the high-water mark for each datafile. This is the absolute number of bytes used, including the free chunks between used data blocks. The size of a datafile can be shrunk to at least this size.

When a table is moved to another tablespace, its indexes must be rebuilt. We have added a grid to the Moving to another tablespace dialog that displays the indexes and their tablespaces. You can use the check boxes to select which ones to rebuild.

Both Reverse/DDL and the DDL generated from the Show DDL menu item on Hora's Users page now support Resource Manager privileges. A call to the Resource Manager package is included in the DDL that defines the user if the current user has the privilege of switching a user from one consumer group to another.

A new Hora menu item, Tablespaces | Show DDL, has been added.

Added context menus to the watches and breakpoints windows of the PL/SQL Debugger, along with the appropriate menu commands.

The PL/SQL Debugger now supports server output for Oracle 8i databases. Whenever the Debugger stops, lines written to dbms_output are displayed in the new dbms_output window.

Version 5.1.2 (2002-02-10)

The new Resource Manager page presents an interface for managing the hierarchy of resource plans and associating them with consumer groups. You can define a default consumer group for a user and switch the consumer group for a session.

The interface to Oracle's auditing facility has also been improved. You can define audit options for such database objects as tables, procedures and directories. You can also apply auditing to selected statements and privileges at the user level. Hora's Auditing page gives you an overview of all audited objects, statements and privileges in the database.

Some problems with locally managed temporary tablespaces have been resolved.

The tablespace context menu now allows the status of a tablespace to be toggled between read-only and read/write.

Added an overview tab to the Performance page. It displays the numeric values from the other pages.

As is known, Reverse/DDL generates CREATE ROLE statements for the roles granted to the schema owner. Now it also generates GRANT statements for the system and role privileges that are granted to the role.

Added an extents grid below the tablespace fragmentation grid that shows all extents with the selected fragment size.

The PL/SQL call interface sheet now supports PL/SQL record parameters.

Version 5.1.0 (2002-01-15)

Added a new Visible Columns ... context menu item to the data contents grid. It opens a modal dialog for changing the order and visibility of the columns.

New Sessions | Transactions tab sheet.

The headings on some data grids are now displayed and managed hierarchically. Related columns are now grouped together as subheadings under major headings. Also, columns that have been repositioned are marked.

A new context menu item called Data Grid | Revert to default column positions restores the default column positions.

Some problems with Oracle 9i client software have now been resolved.

The Data Contents tab sheet now remembers changed column positions for each table until the end of the session.

The display of columns on the Overview Sessions sheet that show information about a file path, for example the client application name column, has been enhanced. In earlier versions, the text was truncated on the right when the cell width was too small to display the full path information. Now Hora preserves the rightmost part of the path and inserts two dots into the middle of the string. This allows you to read the file name rather than the less interesting path information.

The new Materialized Views page replaces the Snapshots page for Oracle 8i databases.

Reverse/DDL now generates Materialized View Logs and Materialized Views for Oracle 8i databases .

Added the Show DDL context menu item to the Sequences, Synonyms, Jobs, DB-Links, Materialized Views, Materialized View Logs, Directories, Libraries and Users pages.

Version 5.0.7 (2001-12-12)

In Hora, you can now right-click on any table to show the corresponding Create Table statement.

Reverse/DDL now supports partitioned tables.

The representation of table and index partitions in Hora has been improved.

The connect dialog now allows you to choose either normal, sysoper or sysdba as the connect mode. This is required in order to connect as SYS to an Oracle 9i database.

The ASCII export dialog now remembers the settings of its last use.

The explain plan outline now shows the number of affected rows (cardinality) and the optimizer costs associated with each node. The tree can be saved to an ASCII file using the right mouse button's context menu.

The Create Tablespace Dialog now conforms to the SAFE (Simple Algorithm for Fragmentation Elimination) specification. See Oracle paper #711 on technet.oracle.com for more information.

The Tablespaces | Segments/Extents sheet now displays statistics about the number of segments and the amount of data used by each combination of owner and segment type. The subordinate grid shows only segments of the selected type.

The new Tablespaces  | Fragmentation sheet shows statistics about the number and size of used extents and free chunks in the selected tablespace.

An user's account now can be locked and unlocked. Locked users are displayed in a grayed font.

Added an incremental search dialog to each MDI child window that has the A..Z navigation buttons in the left, and  overview and multiple detail panes. This dialog appears as soon as you press a letter key while the overview grid has the focus.

Version 5.0.6 (2001-11-20)

Added a new Result to Logfile context menu item to each grid. It fetches the entire result set from the server and dumps the data to the log file.

Added File | Disconnect menu item to Hora and the standalone SQL editor.

The Templates directory (CodeSnip.txt, etc.) is now customizable using the Extras | Settings menu item.

Reverse/DDL now supports nested tables.

A new Help | System Environment Information menu Item  shows details about the configuration of the database server and your workstation. Please attach the information to any customer support request.

For modifications to table data on the Tables | Contents sheet or in SQL Workbench, Hora now insures that the record has not been changed by another user. You can disable this feature through a checkbox in the Extras | Settings dialog.

Version 5.0.5 (2001-11-09)

New DB drag/drop object browser tool window is now available from each embedded and standalone editor.

Ability to edit different PL/SQL objects in separate editor windows.

Enhanced support for partitioned tables and indexes.

F5 button refreshes current tab sheet from the database.

Version 5.0.4 (2001-10-31)

Supports Oracle 9i databases.

Network licensees now can work offline from the network for a maximum period of 30 days. The license accumulator will be reset as soon as the application runs in the network environment again.

Support for creation of local (partitioned), bitmap, reverse or function based indexes.

Fixed some problems with the new licensing procedure affecting certain hardware.

Some minor ease-of-use enhancements.

SQL Editor now highlights Oracle configuration file syntax (TnsNames.ora, etc.).

Version 5.0.3 (2001-09-02)

The new Gateway to the Oracle Documentation is now accessible from any location outside of the Oracle home directory, for example a central directory on your intranet.

Added a Favorites collection to the Sidebar that is fully customizable by the user.

Hora now raises an exception if you try to replace a PL/SQL package that has been changed by another Oracle session.

The detail view of the Roles sheet has been divided into two tab sheets. The first sheet shows the privileges granted to the role. The second sheet shows the grantees, i.e. users and roles that have received grants through the role.

A new Text View context menu item for each data grid allows you to select any subset of rows from the data grid and copy it to another Windows application.

Version 5.0.2 (2001-08-20)

HTML documentation generator now supports views

Online help is now context-sensitive

The connect dialog now remembers the most recently used connections hierarchically. They are ordered first by server names, then by the schemas accessed.

Version 5.0.1 (2001-07-24)

Fixed workstation and floating network licenses

Explain plan dialog displays the current session's optimizer mode.

Tablespaces | Datafiles and Database | Datafiles grids show backup status

New Snapshot Logs page

PL/SQL editor remembers the insertion point location in each PL/SQL object until the database connection is closed.

LOB detail information tab sheet below Tables | Columns

Gateway to ORACLE online documentation added to the Hora Help menu .

The Database Links Overview tab sheet shows  local settings like global_names and default domain initialization parameters at the bottom.

ER Diagrammer now can print over multiple pages.

Version 5.0.0 (2001-06-30)

General

oData grid menu item within each database grid:

record view

filter

locate

ASCII export (Excel, etc.)

Fixed anchor columns

Row height (variable number of lines)

Tables page changes

oImproved create table and create view dialogs

oCreate index on FK columns using the FK context menu

oSupport for partitions and subpartitions

oSearch column, constraint, index or trigger names

oMultiline data contents column captions allow smaller column widths

oFilter by selection extended by a query condition preview dialog.

oNew Access detail page

oDeferrable Constraints Support

oSet column unused

oDisable constraint cascade

oChecks if record was changed by another user in data contents

oReturning clause used in data contents

oDetail subpage in data contents view

oReferenced Constraints subdetail page

oMove table to another tablespaces

oColumn histograms

New Java objects page

Summaries page

Jobs & Pipes page

oNew All Users tab sheet to display all jobs

Tablespace page changes

oSort segments and sort usage subpages

DbLinks page changes

oDistributed transactions

Users page changes

oSchema triggers

oSQL area

Database page changes

oEnable/disable restricted session

oControl file space totals

oControlfiles can be backed up to trace

oDatabase triggers

oSeparate instance page

oDatafiles page

Session page changes

oin statistics page : class info column factored out into a master grid

RedoLog page changes

oChanges grouped by hours to show peaks in the log activity.

oLog Miner page

SQL Page

o&Macro Macro substitution

oDescribe and columns drop-down lists now supports synonyms

oStay-on-top option for query resultset window

Reverse/DDL changes

osupport for database and schema triggers

oDeferrable Constraints Support

ER Diagrammer changes

oenhanced navigation

ocopy to clipboard in meta-file format