Version 6

<< Click to Display Table of Contents >>

Navigation:  Getting Started > KeepTool Release Notes >

Version 6

Previous pageReturn to chapter overviewNext page

Version 6.2.7 (2005-09-02)

The standard connection dialog for KeepTool products now provides the Color Theme drop-down box, which allows users to easily distinguish between multiple sessions.

The Data Contents Browser has been redesigned. Tables and views may now be opened by selecting them from a list and double-clicking. A previously created settings file can now be opened even if some of the tables no longer exist.

Hora can now be automatically started from the command line with the specification AS SYSDBA or AS SYSOPER. For details, please refer to the Command line parameters topic.

Version 6.2.5 (2005-03-24)

SQL Workbench's default node My SQL is now called Personal SQL. This change does not affect current users.

The horizontal ruler in SQL Editor may now be toggled on or off through the Extras | Additional menu.

The Connect dialog has been enhanced to allow access through the 10g Instant Client, using a string formatted as host:port/service name.

Reverse DDL now supports the Tablespace clause for LOB's.

A problem with importing dates from Microsoft Excel has been corrected.

In Database | Roles, when System Privileges is selected with the bottom left tab, only the Grantees bottom tab is enabled on the right.

An Oracle Data Access Components problem that occasionally showed blank cells in the Tables | Data Contents grid has been corrected.

In Overview Tables, the Case-Sensitive check box in the filter dialog has now been turned off by default.

Version 6.2.4 (2004-11-03)

The Connect Dialog has added a new field that allows optional entry of a tag whose text will form part of the main window's title bar and the taskbar button for the session.

Various minor changes to improve efficiency.

Version 6.2.3 (2004-10-01)

Performance of Tables | Data Contents and the Data Contents Browser has been improved by runtime caching of metadata for subsequent queries.

The DROP TABLESPACE dialog now offers the AND DATAFILES option for 9i and 10g databases.

Hora's startup performance has been enhanced by eliminating automatic calls to DBMS_JAVA. On the Extras | Settings menu, it is now possible to set Java Server output on or off separately from DBMS_OUTPUT, and to set the buffer size. The default is now Java output disabled, and DBMS_OUTPUT enabled, with a buffer size of 20,000 lines for each.

On Hora's Tables page, it is now possible to create primary and unique keys  from the Columns | Constraints detail grid, in the same manner as on the Constraints sheet.

HTML Documentation Generator's connect dialog now offers the possibility of a direct TCP/IP connection.

Version 6.2.2 (2004-09-01)

A list of the current contents of the Data Contents Browser can now be saved to a user-specified XML file. On re-entering the Browser, all tables and views can be brought back into the window via the new Load button.

Hora now offers the ability to cancel long-running queries in the SQL Workbench, Tables | Data Contents and the Data Contents Browser. A new checkbox in Extras | Settings asks the user if he wants to cancel the query. It appears after 2 seconds in Windows XP, or for all queries in earlier versions of Windows. See the new topic Cancel Query  for details. (This feature is not available with a TCP/IP connection.)

Enhancements have been made to the customization dialogs for the standalone SQL Editor and to the built-in editor in Hora's code windows, most significantly in the Colors dialog. As a result, new default settings are in place. These may be replaced and saved for future use. Details are available in Customizing the Editor.

The Search dialog that can be accessed from the Overview Packages page (described in the dialog Search PL/SQL Text) now allows for searches within all categories of PL/SQL object, or just within the category pointed to by the bottom tab.

Hora's settings now add the option of disabling Windows Ghosting. This option affects only Windows XP SP1, and prevents situations where windows cannot be closed after switching between Hora and other Windows applications.

Another new setting determines whether execution time will be shown in the DBMS_Output window when using the Execute Query function.

Hora's CREATE VIEW dialog now automatically qualifies the view name with the current schema name. This prevents an Oracle error message that was previously generated when the schema selector box was used to manage another user's schema.

Version 6.2.1 (2004-08-09)

On Tables | Data Contents and in the Data Contents Browser, a new XML export facility has been added.

On Tables | Triggers, the display of columns affected by triggers has been enhanced.

The Reports Facility now permits export to an Excel file, and data fields in the Report Designer include references to variable names.

In the SQL Workbench's Results grid, the reference to AutoCommit in the window caption has been removed.

The CREATE TABLE dialog, Tables | Columns , and DDL Generation now allow for input and display of explicit length semantics qualifiers BYTE and CHAR for CHAR and VARCHAR2 datatypes. This is shown in Reverse DDL Engineer and HTML Documentation Generator, in addition to Hora.

The redundant fields LAST_SEC, THIS_SEC, NEXT_SEC in Overview Jobs have been removed.

In Users | SQL Area, buttons for Filter, Find and Flush SQL Area have been added.

On Hora's Materialized Views overview, additional information regarding refresh groups has been added to the grid. A new Logging checkbox has been added to the CREATE MATERIALIZED VIEW dialog. The query that produces the overview for an 8.1.7 database was modified to prevent the display of erroneous values in ALL_MVIEWS.COMPILE_STAT.

In Tablespaces | Datafiles, a context menu item to drop a tempfile has been added.

Hora's Data Contents Browser now shows the current row and the number of rows fetched in the status bar in the same way as the Tables | Data Contents page.

In Hora's Packages page, the source code of a PL/SQL unit that is opened in a separate editor now retains editor settings in the same way as the source code window. The Find Procedure function in the separate editor window now also functions in the same way as on the Source Code tab sheet.

Check marks in grids are no longer encased in boxes.

Version 6.2.0 (2004-06-21)

All KeepTool products now support access to the Oracle 10g server via the 10g client's Oracle Call Interface.

In Hora, a new option has been added to the general options menu that is available through Extras | Settings. AutoCommit causes inserts, updates, and deletes that are made through the grids on Tables | Data Contents and in the Data Contents Browser to be automatically committed. In previous versions of Hora, AutoCommit was automatically in effect. This option may now be set off by unchecking the box.

For Oracle 10g databases, the status of the Flashback Database may now be viewed through a new tab on the Redo Logs page.

The context menu for Overview Tablespaces now allows renaming of tablespaces in Database 10g.

On the Overview Tables tab sheet, three new flags have been added: Dependencies, Compression, and Dropped. The third indicates that a table has been dropped, but not purged, from an Oracle 10g database, and is in the Recycle Bin. On Tables | Indexes, a new Dropped flag indicates that an index has been dropped and is in the Recycle Bin.

The Oracle Data Access Components used by KeepTool now support Transparent Application Failover (TAF), which automatically re-establishes a connection to the server when the prior connection fails.

Version 6.1.1 (2004-04-28)

All KeepTool products now support access to the Oracle 10g server via the 10g client's Oracle Call Interface.

Hora now supports the Oracle Database 10g Server.

The link to Oracle Reference, SQL Reference, and Error Messages, formerly on the Help menu, has been replaced by an all-encompassing link to Oracle Help from theSearch context menu in all of Hora's code windows and the standalone SQL Editor.

Support for Merant® Version Manager™ has been added in SQL Workbench's File Explorer.

Hora's Query Builder now allows adding related tables from a selected table's context menu.

It is now possible to drop multiple objects in Hora, by holding down the Ctrl key when selecting objects. A Confirm drop window is displayed and must be acknowledged before proceeding.

New filtering options have been added to the Data Contents Browser and the Data Contents sheet of the Tables page. They allow the definition of an ad hoc relationship between tables.

Both the Data Contents Browser and the Data Contents sheet of the Tables page now enable the memo editor for columns defined as XMLTYPE, and for tables defined as TABLE OF XMLTYPE.

In Hora's list-filtering dialogs, reachable via the Data Grid | Filter context menu item or the Filter button on the Toolbar, two new options are available: case-sensitive and non-matching records.

The width of columns in all of Hora's grids may now be decreased to allow them to be narrower than the width of the column headings.

In Hora's Overview Packages, Procedures, Functions sheet, new tabs showing information taken from the V$DB_OBJECT_CACHE view that pertains to the highlighted item is now shown.

The source code windows for PL/SQL objects now automatically include a  slash (/) at the end, to facilitate execution if they are saved to external files.

Hora's Schema page has been moved from the bottom to the top of the Additional collection.

On Hora's Schema page, it is now possible to see DDL for grants of object privileges made by the schema owner to others.

A new sheet, Schema Triggers, has been added to Hora's Schema page.

The colors of the type and background in Hora's Sidebar are now customizable from the Startup tab of Extras | Settings.

On Hora's Tablespace page, the Datafiles tab sheet has been enhanced to include STATUS from V$DATAFILE, showing whether datafiles are online or offline.

Batch invocation of HTML Documentation Generator adds many new options, including the ability to generate an HTML file while bypassing the options dialog completely.

Version 6.1.0 (2004-01-12)

In Hora's SQL Workbench, support has been added for source code management systems that conform to the Microsoft SCC interface, beginning with Microsoft Visual SourceSafe.

Hora's Standard Sidebar contains a new item: the Data Contents Browser, which facilitates viewing and updating of several tables or views at once.  An option enables automatic filtering to show only rows related to a selected row in the previously viewed table.

Hora's Data Contents sheet on the Tables page has been enhanced to allow viewing of any user-selected table along with the related detail tables. Also, the Arrange Columns dialog has been enhanced to present two new options for selecting columns to be displayed: Select All and Unselect All.

The Advanced Button in the Connection Dialog for all three products now gives the user the ability to choose among existing oci.dll files for all Oracle Homes using a combo box.

In all of Hora's code windows, and in SQL Editor, a new context menu item has been added that will comment multi-line selected text with /* */ symbols.

For schemas, tables and indexes, Hora now offers new options for analyzing statistics.

Version 6.0.2 (2003-12-02)

The EMS Import and Export facilities on Hora's Table page and on SQL Results added support for the Microsoft Access (.mdb) format. You must have ActiveX Data Objects (ADO) installed to enable this option.

In Hora's Data Contents page, TIMESTAMP columns are now correctly displayed when using an Oracle 9.2 oci.dll.

The Context menu for table shapes in Hora's Query Builder now offers options for presenting the order of table columns.

Hora's Query Builder now allows for both tables and views to be incorporated into the query.

Hora now uses the SELECT ANY DICTIONARY privilege (in place of SELECT ANY TABLE) with Oracle 9i databases to determine whether Data Dictionary views should be displayed for users who have not been granted the HORA_USER role.

Version 6.0.1 (2003-10-24)

A new option has been added to Hora's Extras | Settings menu. It determines whether a dialog will be presented after each DML statement to enable the user to choose between a Commit, a Rollback, or continuing the transaction until a future time. A commit or rollback may now be done via new Toolbar buttons or via the File Menu.

A new context menu item and Toolbar button has been added to Hora's SQL Workbench. It allows the contents of the code window to be sent to a SQL*Plus session for execution and output to be viewed in the DBMS_OUTPUT window.

On Hora's Data Contents tab for Tables, a context menu item now allows loading BLOBs and CLOBs from files and saving them to files.

On Hora's Schema | Policy tab, new context menu items to add or drop a security policy have been added.

On Hora's Tables | Columns tab sheet, a new dialog to control the visibility and order of columns can now be invoked by clicking the area in the upper left corner of the grid.

Hora's Redo Logs page has added a new sheet to show archived log data.

Hora's Report facility now has the ability to save reports in various formats, including .pdf and .rtf.

Hora's SQL Query Builder adds a checkbox that allows columns to be used in WHERE clauses without being SELECTed.

The SQL Editor's customization options (standalone and embedded) now include a new Additional category, where it is possible to set highlighting of the current line on or off.

The File Explorer in Hora's SQL Workbench now displays additional file types such as .sqs and .tab created by Oracle Designer.

Several miscellaneous minor enhancements.

Version 6.0.0 (2003-09-07)

The design of the user interfaces for all of KeepTool's products has been modified to allow the interface to follow the currently selected Windows XP design.  In Windows XP, the currently selected tab on all tab sheets is now outlined in orange. The majority of the icons in all products have been updated to show more detail and more color.

Hora: The SQL Query Builder has been replaced by a new version that allows tables and columns to be shown graphically, with joins for table relationships being automatically generated. Query Builder now also generates code for cursor "for" loops, in addition to SELECT, INSERT and UPDATE statements. The new facility is covered in the SQL Query Builder topic under Modal Dialogs.

Hora: New Export and Import dialogs have been added to both the Tables | Data Contents sheet and the Results grid in the SQL Workshop. These facilities are described under two new topics in the Modal Dialogs: EMS File Export and EMS File Import.

Hora: A new Report facility has been added to both the Tables | Data Contents and the Results grid in the SQL Workshop. This facility is described in the Modal Dialogs under the new topic Reporting.

Hora and SQL Editor: A new File Comparison facility has been added to the SQL Workbench. It is accessible from both the SQL Repository and File Explorer tabs, and can be used to compare any two text files. This facility is also available from the File Menu in the standalone SQL Editor. It is described in Modal Dialogs under the topic File Comparison.

Hora: Two new buttons have been added to the left end of the Toolbar, and are available for most operations that allow updates by typing in a data grid: Commit and Rollback.

Hora and SQL Editor: Both Hora's SQL Workbench and the SQL Editor now display column numbers in the code window.

Hora: The Execute Script function in SQL Workbench now ignores SQL*Plus commands. This allows the SQL commands and PL/SQL blocks in scripts to run without interruption.

Hora: The Execute Script function now shows results from SELECT statements in the DBMS_OUTPUT window, where they can be further manipulated.

Hora: A new Schema page has been added to the Additional Sidebar. The page gives information about the status of all objects within the currently selected schema, without regard to the type of object.

Hora: The Grant System Privileges dialog, found under both Database | Roles and Users | Roles & Privileges, now uses icons to distinguish between roles and privileges, and adds a checkbox to facilitate multiple grants.

Hora: The Privileges tab sheet of the Tables page has been redesigned to show grantees and privileges through a grid.

Hora: All grid columns can now be resized. Double-clicking a column boundary will set the column size to that of the largest cell. Pressing the Alt key when selecting a text area with the mouse enables selecting a rectangular block of text.

Hora: On the Database page, port string, version and compatibility have been added. All options, whether installed or not, are shown, with unavailable options in gray.

Hora: The Schema | Clear Schema menu option now gives detailed information about objects that cannot be dropped, such as public synonyms.

Reverse DDL Engineer: A filter condition can now be applied when specifying objects to be included individually.

When creating new foreign-key relationships in ER Diagrammer, new foreign key names are now shown automatically without the need to update the diagram.

When ER Diagrammer has been started from a saved .dgr file, a connection dialog is automatically presented after any attempt to update the diagram.